
        <!doctype html>
        <html xmlns:og="http://ogp.me/ns#" lang="en">
            <head>
                <link href="/manifest.json" rel="manifest">
                <script type="application/ld+json">
        {"@context":"http://schema.org","@type":"NewsArticle","author":[{"@type":"Person","name":"Debby Wu"},{"@type":"Person","name":"Mark Gurman"}],"dateCreated":"2018-08-05T10:57:08.085Z","dateModified":"2018-08-06T02:28:27.638Z","datePublished":"2018-08-05T10:57:08.085Z","description":"Taiwan Semiconductor Manufacturing Co., which makes chips for the iPhone and other devices, is recovering from a debilitating computer virus but warned of delayed shipments and reduced revenue because of the impact on its factories.","headline":"iPhone Chipmaker Races to Recover After Crippling Computer Virus","image":{"@type":"ImageObject","url":"https://assets.bwbx.io/images/users/iqjWHBFdfxIU/iSi6MA13on0A/v1/-1x-1.jpg","width":1999,"height":1333},"mainEntityOfPage":"https://www.bloomberg.com/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus","publisher":{"@type":"Organization","name":"Bloomberg","logo":{"@type":"ImageObject","url":"https://assets.bwbx.io/s3/javelin/public/javelin/images/bloomberg-logo-amp-e995e81f26.png","width":262,"height":60}}}
    </script>
                
        <link href="https://assets.bwbx.io" rel="preconnect" crossorigin>
        <link href="https://nav.bloomberg.com" rel="preconnect" crossorigin>
    
                <link rel="stylesheet" type="text/css" href="https://assets.bwbx.io/font-service/css/BWHaasText-56Italic,BWHaasHead-55Roman,BWHaasHead-56Italic,BWHaasHead-75Bold,BW Haas Text Mono A-55 Roman,TiemposTextWeb-Regular,TiemposTextWeb-RegularItalic,TiemposHeadlineWeb-Bold,AvenirNext-Demi,supriasans-regular-web,supriasans-black-web,supriasans-bold-web,PublicoText-Roman-Web,PublicoText-Italic-Web,PublicoText-Bold-Web,Bloomberg Logotypes-Medium,BWHaasGrotesk-95Black-Web,BWHaasGrotesk-75Bold-Web,BWHaasGrotesk-55Roman-Web,PublicoHeadline-Black-Web,PublicoHeadline-Bold-Web,PublicoHeadline-Light-Web,PublicoHeadline-Roman-Web/font-face.css">
                <link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/application/application-2bfc79a60b.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
                <link href="https://assets.bwbx.io/font-service/css/Bloomberg%20Logotypes-Medium,BWHaasGrotesk-75Bold-Web,BWHaasGrotesk-95Black-Web,BWHaasGrotesk-55Roman-Web/font-face.css" rel="stylesheet"><link href="https://assets.bwbx.io/s3/navi/css/components/bar/bar-f68ff489cd.css" rel="stylesheet"><link href="https://assets.bwbx.io/s3/navi/vendor/css/reg-ui-client-162e0da6e2.css" rel="stylesheet"><noscript><style>.noscript-hide{display:none;}.navi-bar__button--subscribe{margin-right:20px;}</style></noscript>
                <link href="https://www.bloomberg.com/tophat/assets/v2.0.2/that.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
                <link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/abstract_redesign/abstract_redesign-56f4ac5dad.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/abstract_redesign/abstract_redesign-2a5b88c903.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/text_to_speech/text_to_speech-b42303bc0e.tablet-desktop.css" media="(min-width:761px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/text_to_speech/text_to_speech-e1d7758e2f.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/author_tout/author_tout-28d2b47b89.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/author_tout/author_tout-e273b6df99.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/author_details/author_details-e4274d7c90.css" media="all" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/blens/blens-493e6da53f.css" media="all" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/body-de2481eb23.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/newsletter_tout-7104a5317e.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/outstream_ad-c21b3ed6be.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/transporter_teaser-5b383e0ef5.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/body-936a1a2ec2.desktop.css" media="(min-width:1021px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/in_article_ad-238ed3378a.desktop.css" media="(min-width:1021px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/transporter_teaser-5a3d6673ac.desktop.css" media="(min-width:1021px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/body-3f153831c7.small_desktop.css" media="(min-width:1021px) and (max-width:1280px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/body-c30c8a74a5.large_desktop.css" media="(min-width:1281px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/transporter_teaser-30af2d9325.large_desktop.css" media="(min-width:1281px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/body-e886f59cb3.tablet-desktop.css" media="(min-width:761px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/mobile_ads-10915d4c59.tablet-desktop.css" media="(min-width:761px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/body-95109a276f.tablet.css" media="(min-width:761px) and (max-width:1020px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/in_article_ad-03e2f31c27.tablet.css" media="(min-width:761px) and (max-width:1020px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/transporter_teaser-5a3d6673ac.tablet.css" media="(min-width:761px) and (max-width:1020px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/in_article_ad-b789d79511.mobile-tablet.css" media="(max-width:1020px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/body-fef775f6ab.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/in_article_ad-a8500fe5ea.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/mobile_ads-95f94f08a6.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/newsletter_tout-12eaa8fd13.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/body/basic_redesign/transporter_teaser-2478dd6d94.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/charts/charts-32a083a3ea.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/charts/charts-2a9dffa69a.desktop.css" media="(min-width:1021px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/charts/charts-6724cab530.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ledes/basic_redesign/lede_text_v2/lede_text_v2-85a42f3eff.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ledes/basic_redesign/lede_text_v2/lede_text_v2-03a87dfce3.desktop.css" media="(min-width:1021px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ledes/basic_redesign/lede_text_v2/lede_text_v2-6a0fa12efe.small_desktop.css" media="(min-width:1021px) and (max-width:1280px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ledes/basic_redesign/lede_text_v2/lede_text_v2-be4a698eb9.large_desktop.css" media="(min-width:1281px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ledes/basic_redesign/lede_text_v2/lede_text_v2-e0847fc7e1.tablet.css" media="(min-width:761px) and (max-width:1020px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ledes/basic_redesign/lede_text_v2/lede_text_v2-73409f9602.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ledes/basic_redesign/lede_small_image_v2/lede_small_image_v2-a10cd11739.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ledes/basic_redesign/lede_small_image_v2/lede_small_image_v2-9c5f7e17e3.desktop.css" media="(min-width:1021px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ledes/basic_redesign/lede_small_image_v2/lede_small_image_v2-70412d06a5.large_desktop.css" media="(min-width:1281px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ledes/basic_redesign/lede_small_image_v2/lede_small_image_v2-9c5f7e17e3.tablet.css" media="(min-width:761px) and (max-width:1020px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ledes/basic_redesign/lede_small_image_v2/lede_small_image_v2-d05852efac.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/recirc_redesign/recirc_redesign-de6894c9e4.css" media="all" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/mini_player/mini_player-dbb7cd7b15.desktop.css" media="(min-width:1021px)" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ads/terminal_tout_redesign/terminal_tout-d1228ab4f8.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ads/terminal_tout_redesign/terminal_tout-f9356f0bf2.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ads/secure_tip_tout_redesign/secure_tip_tout-d377a63cbc.css" media="all" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/share_article_button/share_article_button-1f0b812ef6.tablet-desktop.css" media="(min-width:761px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/share_article_button/share_article_button-5195f9654c.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css">
                
                <link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/image_viewer/image_viewer-1e5746c2c1.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/image_viewer/image_viewer-058810df2a.desktop.css" media="(min-width:1021px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/image_viewer/image_viewer-94b75c625f.mobile-tablet.css" media="(max-width:1020px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/image_viewer/image_viewer-eeba583cbe.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css">
                <link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/layout/basic_redesign/basic-5f25fe7ffd.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/layout/basic_redesign/basic-cb5f4999f8.desktop.css" media="(min-width:1021px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/layout/basic_redesign/basic-6ca7591c4f.small_desktop.css" media="(min-width:1021px) and (max-width:1280px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/layout/basic_redesign/basic-eff43b3fd0.large_desktop.css" media="(min-width:1281px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/layout/basic_redesign/basic-eb212fdc2e.tablet.css" media="(min-width:761px) and (max-width:1020px)" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/layout/basic_redesign/basic-7b4af698cd.mobile.css" media="(max-width:760px)" property="stylesheet" rel="stylesheet" type="text/css">
                <link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/pianola/pianola_css-bc5ce39b50.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
                <link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ads/leaderboard/leaderboard-f7160e7776.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
<link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/ads/leaderboard/leaderboard-290beb4fc2.tablet-desktop.css" media="(min-width:761px)" property="stylesheet" rel="stylesheet" type="text/css">
                
                <link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/components/lazy_images/lazy_image-7dc0452705.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
                <link href="https://assets.bwbx.io/font-service/css/Bloomberg/font-face.css" media="all" property="stylesheet" rel="stylesheet" type="text/css"><link href="https://assets.bwbx.io/s3/bbnav/public/stylesheets/bb-global-footer-14728f6f87.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
                <link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/unsupportedBrowserMessage/unsupportedBrowserMessage-ce08ced21c.css" media="all" property="stylesheet" rel="stylesheet" type="text/css">
                <link href="https://assets.bwbx.io/s3/javelin/public/javelin/css/print_redesign/print-2a6c31fe6b.css" media="print" property="stylesheet" rel="stylesheet" type="text/css">
                
        <title>iPhone Chipmaker Races to Recover After Crippling Computer Virus - Bloomberg</title>
        <link rel="canonical" href="https://www.bloomberg.com/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus">
        <meta name="description" content="Taiwan Semiconductor Manufacturing Co., which makes chips for the iPhone and other devices, is recovering from a debilitating computer virus but warned of delayed shipments and reduced revenue because of the impact on its factories.">
        <meta name="iso-8601-publish-date" content="2018-08-05T10:57:08.085Z">
        <meta name="checksum" content="47bc8fd3cc5ca4f20abef80bfe617396">
        <meta name="validatedAt" content="2018-08-07T03:00:22.295Z">
        <meta name="referrer" content="unsafe-url">
        <meta name="referrer" content="always">
        <meta property="al:android:url" content="bloomberg://www.bloomberg.com/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus?utm_medium=applink&utm_source=facebook">
        <meta property="al:android:package" content="com.bloomberg.android.plus">
        <meta property="al:android:app_name" content="Bloomberg">
        <meta property="og:description" content="Taiwan Semiconductor Manufacturing Co., which makes chips for the iPhone and other devices, is recovering from a debilitating computer virus but warned of delayed shipments and reduced revenue because of the impact on its factories.">
        <meta property="og:image" content="https://assets.bwbx.io/images/users/iqjWHBFdfxIU/iSi6MA13on0A/v1/1200x800.jpg">
        <meta property="og:site_name" content="Bloomberg.com">
        <meta property="og:title" content="iPhone Chipmaker Races to Recover After Crippling Computer Virus">
        <meta property="og:type" content="article">
        <meta property="og:url" content="https://www.bloomberg.com/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus">
        <meta name="fb:status" content="Taiwan Semiconductor is racing to recover from a crippling computer virus and has warned of delayed shipments.">
        <meta name="twitter:card" content="summary">
        <meta name="twitter:description" content="Taiwan Semiconductor Manufacturing Co., which makes chips for the iPhone and other devices, is recovering from a debilitating computer virus but warned of delayed shipments and reduced revenue because of the impact on its factories.">
        <meta name="twitter:image" content="https://assets.bwbx.io/images/users/iqjWHBFdfxIU/iSi6MA13on0A/v1/1200x800.jpg">
        <meta name="twitter:site" content="@technology">
        <meta name="twitter:title" content="iPhone Chipmaker Races to Recover After Crippling Computer Virus">
        <meta name="parsely-title" content="iPhone Chipmaker Races to Recover After Crippling Computer Virus">
        <meta name="parsely-link" content="https://www.bloomberg.com/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus">
        <meta name="parsely-type" content="post">
        <meta name="parsely-image-url" content="https://assets.bwbx.io/images/users/iqjWHBFdfxIU/iSi6MA13on0A/v1/1200x800.jpg">
        <meta name="parsely-pub-date" content="2018-08-05T10:57:08.085Z">
        <meta name="parsely-section" content="technology">
        <meta name="parsely-tags" content="iPhone,TAIWAN SEMICONDUCTOR MANUFAC,APPLE INC,Software,QUALCOMM INC,US Dollar Spot,Taipei,Taiwan,Mark Li,Smartphone,Secondary Brand: business,Secondary Brand: technology,Region: Global,Page: article">
        <meta name="parsely-post-id" content="PCZCXF6S972801">
        <meta name="parsely-author" content="Debby Wu">
<meta name="parsely-author" content="Mark Gurman">
        
        <script type="text/javascript">
            (function(w) {
                w.dataLayer = w.dataLayer || [];
                w.dataLayer.push({"adcode":"business/news/technology","author":"Debby Wu and Mark Gurman","publishedAt":"2018-08-05T10:57:08.085Z","storyId":"PCZCXF6S972801","contentType":"content-article","pageType":"content","template":"javelin-article-html","topic":"iPhone","attributor":"bn","brand":"technology","secondaryBrands":"business,technology","franchise":null,"categories":"technology","transporter":"false","refresh":"false","headline":"iPhone Chipmaker Races to Recover After Crippling Computer Virus","slug":"2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus","tags":"iPhone,TAIWAN SEMICONDUCTOR MANUFAC,APPLE INC,Software,QUALCOMM INC,US Dollar Spot,Taipei,Taiwan,Mark Li,Smartphone,business,technology","siteId":"technology","resourceType":"article","resourceId":"PCZCXF6S972801"});
            })(window);
        </script>
    
        
    <link rel="icon"
        type="image/png"
        href="https://assets.bwbx.io/s3/javelin/public/javelin/images/favicon-black-63fe5249d3.png">
    
    
                <link rel="amphtml" href="https://www.bloomberg.com/amp/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus" />
                
        <meta charset="utf-8">
        <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, viewport-fit=cover">
        <meta name="apple-mobile-web-app-capable" content="no">
        <meta name="apple-mobile-web-app-status-bar-style" content="black">
        <meta name="apple-itunes-app" content="app-id=281941097, affiliate-data=ct=smartbanner_mobileweb&pt=8949&utm_source=smart_banner">
    
                
        <meta name="sailthru.title" content="iPhone Chipmaker Races to Recover After Crippling Computer Virus">
        <meta name="sailthru.author" content="Debby Wu,Mark Gurman">
        <meta name="sailthru.tags" content="iPhone,TAIWAN SEMICONDUCTOR MANUFAC,APPLE INC,Software,QUALCOMM INC,US Dollar Spot,Taipei,Taiwan,Mark Li,Smartphone,business,technology">
        <meta name="keywords" content="iPhone,TAIWAN SEMICONDUCTOR MANUFAC,APPLE INC,Software,QUALCOMM INC,US Dollar Spot,Taipei,Taiwan,Mark Li,Smartphone,business,technology">
        <meta name="sailthru.description" content="Taiwan Semiconductor Manufacturing Co., which makes chips for the iPhone and other devices, is recovering from a debilitating computer virus but warned of delayed shipments and reduced revenue because of the impact on its factories.">
        <meta name="sailthru.date" content="2018-08-05T10:57:08.085Z">
    
                <script>!function(){if(!(Math.random()>.1||window.BOOMR&&window.BOOMR.version)){var e,t,n,o=document.createElement("iframe"),a=window;a.addEventListener?a.addEventListener("load",i,!1):a.attachEvent&&a.attachEvent("onload",i),o.src="javascript:void(0)",o.title="",o.role="presentation",(o.frameElement||o).style.cssText="width:0;height:0;border:0;display:none;",(n=document.getElementsByTagName("script")[0]).parentNode.insertBefore(o,n);try{t=o.contentWindow.document}catch(n){e=document.domain,o.src="javascript:var d=document.open();d.domain='"+e+"';void(0);",t=o.contentWindow.document}t.open()._l=function(){var t=this.createElement("script");e&&(this.domain=e),t.id="boomr-if-as",t.src="https://s.go-mpulse.net/boomerang/T6PPY-X9KZV-8VZ6F-7N5GB-F8ELN",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(t)},t.write('<body onload="document._l();">'),t.close()}function i(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}}();</script>
            </head>
            <body data-theme="technology" data-type="article">
                
        <script>
            window._fence = (function(d, s, l, id, cdn, v) {
                var fs, st, lt, pf, ft, f = window._fence || {};
                if (d.getElementById(id)) return f;
                fs = d.scripts[0];
                st = d.createElement(s);
                lt = d.createElement(l);
                pf = d.createElement(l);
                ft = d.createElement(l);
                pf.rel = "dns-prefetch"; pf.href = cdn;
                st.id = id; st.async = true; st.src = cdn + "/s3/fence/" + v + "/app.bundle.js";
                lt.rel = "stylesheet"; lt.href = cdn + "/s3/fence/" + v + "/styles.css";
                ft.rel = "stylesheet"; ft.href = "https://assets.bwbx.io/font-service/css/BWHaasGrotesk-55Roman-Web,BWHaasGrotesk-75Bold-Web,Bloomberg/font-face.css";
                f.q = [];
                f.nq = [];
                f.ready = function(cb) {
                  f.q.push(cb);
                };
                f.notReady = function(cb) {
                    f.nq.push(cb);
                };
                d.head.appendChild(pf);
                d.head.appendChild(lt);
                d.head.appendChild(ft);
                fs.parentNode.insertBefore(st, fs);
                return f;
            }(document, "script", "link", "fence-snippet", "//assets.bwbx.io", "v4"));

            window._fence.ready(function() {
                window._fence
                    .enableRender({"hideContentConfig":{"exist":".fence-body","hide":"*:not(p):not(a):not(em):not(h1):not(h2):not(h3):not(h4):not(span):not(strong), p:nth-of-type(n+2) ~ *","hideContainerDirective":"EXIST","inlineContainerDirective":"EXIST"}})
                    .addArticle("PCZCXF6S972801", true, "technology");

                window.__bloomberg__.eventBus.publish("init-pianola");
            });
        </script>
    
                <script type="text/javascript">window.__bloomberg__=window.__bloomberg__||{};window.__bloomberg__.environment={"playlistPlayerEnabled":true,"psznTrackingUrl":"https://tracking.bloomberg.com/images/tracking-pixel.gif","psznRecommendationUrl":"https://personalization.bloomberg.com","blensSnippetUrl":"https://www.bloomberg.com/markets/modules/datastrip.json?version=2","registrationEnv":"production","tickerToutEnabled":true,"tickerToutUrl":"https://www.bloomberg.com/markets/modules/datastrip?version=2","videoPlayerUrl":"https://cdn.gotraffic.net/projector/latest/bplayer.js"};</script>
                <script src="https://assets.bwbx.io/s3/javelin/public/javelin/js/components/event_bus/event_bus-a9f299e831.sync.js" type="text/javascript"></script>
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/pwa/pwa-d9e2e840ed.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
                
        <script type="text/javascript">
            (function () {
                if(typeof window.CustomEvent === "function") return false;
                function CustomEvent(event, p) {
                    p = p || {bubbles: false, cancelable: false, detail: undefined};
                    var e = document.createEvent("CustomEvent");
                    e.initCustomEvent(event, p.bubbles, p.cancelable, p.detail);
                    return e;
                }
                CustomEvent.prototype = window.Event.prototype;
                window.CustomEvent = CustomEvent;
            })();
        </script>
    
                
        <script type="text/javascript">
            window.__bloomberg__.ads = {};
            window.__bloomberg__.ads.queue = [];

            window.__bloomberg__.ads.enqueue = function(id) {
                if (window.__bloomberg__.ads.render) {
                    return window.__bloomberg__.ads.render(id);
                }
                window.__bloomberg__.ads.queue.push(id);
            };
        </script>
    
                
    <div class="leaderboard-container">
        <div id="leaderboard-Tx4JUFy" class="leaderboard" data-position="leaderboard">
            <script type="text/javascript">
                window.__bloomberg__.ads.enqueue("leaderboard-Tx4JUFy");
            </script>
            <script class="params" type="application/json">{"contentId":"PCZCXF6S972801","position":"leaderboard","dimensions":{"large_desktop":[[728,90],[970,250],[5,16],[1,1]],"small_desktop":[[728,90],[970,250],[5,16],[1,1]],"tablet":[[728,90],[5,16],[1,1]],"mobile":[[5,16],[1,1]]},"strategy":"viewable","type":"Top Leaderboard Ad","positionIncrement":1,"targeting":{"position":"leaderboard","positionIncrement":1,"url":"/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus"},"containerId":"leaderboard-Tx4JUFy"}</script>
            <div class="leaderboard-ad-dummy"></div>
        </div>
    </div>
    
                <style>
@font-face {
    font-family: 'AvenirNextPForBBG-Regular';
    
    
    src: url('https://assets.bwbx.io/font-service/fonts/AvenirNextPForBBG-Regular-09359fef74.woff2') format('woff2'),
         url('https://assets.bwbx.io/font-service/fonts/AvenirNextPForBBG-Regular-91967b382a.woff') format('woff');
}

@font-face {
    font-family: 'AvenirNextPForBBG-Demi';
    
    
    src: url('https://assets.bwbx.io/font-service/fonts/AvenirNextPForBBG-Demi-62597c630e.woff2') format('woff2'),
         url('https://assets.bwbx.io/font-service/fonts/AvenirNextPForBBG-Demi-d7e488b711.woff') format('woff');
}
#bb-that a{text-decoration:none}#bb-that .bb-that__sitemap{overflow:hidden;position:relative}#bb-that .bb-that__sitemap{max-height:0;-webkit-transition:max-height 0.6s ease-in-out;-o-transition:max-height 0.6s ease-in-out;transition:max-height 0.6s ease-in-out}#bb-that{background:#000;position:relative}@media (max-width: 759px){#bb-that .bb-that{display:none}}#bb-that .bb-that--container{margin:0 auto;padding:0 30px;box-sizing:content-box}@media (min-width: 1020px){#bb-that .bb-that--container{padding:0}}#bb-that .bb-that--container:before,#bb-that .bb-that--container:after{content:" ";display:table}#bb-that .bb-that--container:after{clear:both}@media (min-width: 760px){#bb-that .bb-that--container{width:680px}}@media (min-width: 1020px){#bb-that .bb-that--container{width:980px}}@media (min-width: 1280px){#bb-that .bb-that--container{width:1160px}}#bb-that .bb-that-header{font-family:"AvenirNextPForBBG-Demi","Helvetica Neue",Helvetica,Arial,sans-serif;font-size:15px;line-height:30px;padding:15px}@media (min-width: 760px){#bb-that .bb-that-header{font-family:"AvenirNextPForBBG-Demi","Helvetica Neue",Helvetica,Arial,sans-serif;font-size:12px;height:30px;padding:0}}#bb-that .bb-that-header__link{position:relative;display:block}@media (min-width: 760px){#bb-that .bb-that-header__link{display:inline-block;padding:0 12px}}#bb-that .bb-that-header__link,#bb-that .bb-that-header__link>span{color:#f3f4ef;font-family:inherit;font-size:inherit;line-height:inherit}@media (min-width: 760px){#bb-that .bb-that-header__link,#bb-that .bb-that-header__link>span{line-height:1;-webkit-font-smoothing:subpixel-antialiased;-moz-osx-font-smoothing:auto}}#bb-that .bb-that-header__link:first-child{padding-left:0}#bb-that .bb-that-header__link:after{font-size:9px;position:absolute}@media (min-width: 760px){#bb-that .bb-that-header__link+.bb-that-header__link{border-left:1px solid #b3b3b3}#bb-that .bb-that-header__link+.bb-that-header__link:after{top:-3px}}#bb-that .bb-that-header__link>span:first-of-type{display:inline}#bb-that .bb-that-header__link>span:first-of-type+span{display:none}@media (max-width: 1019px){#bb-that .bb-that-header__link>span:first-of-type{display:none}#bb-that .bb-that-header__link>span:first-of-type+span{display:inline}}#bb-that .bb-that-header--sitemap-trigger{padding:0 27px 0 12px}#bb-that .bb-that-header--sitemap-trigger:after{display:inline-block;content:url("data:image/svg+xml,%3Csvg%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%20viewBox%3D%270%200%2015%2015%27%3E%3Cpath%20d%3D%27M0,2.5l7.5,10l7.5-10H0z%27%20fill%3D%27%23fff%27%2F%3E%3C%2Fsvg%3E");height:9px;width:9px;line-height:initial;opacity:0.7;-webkit-transition:opacity 0.1s ease-out;-o-transition:opacity 0.1s ease-out;transition:opacity 0.1s ease-out}#bb-that .bb-that-header--sitemap-trigger:hover:after{opacity:1}#bb-that .bb-that-header--sitemap-trigger:after{height:9px;width:9px;-webkit-transform:rotate(0);-ms-transform:rotate(0);-o-transform:rotate(0);transform:rotate(0);-webkit-transition:transform 0.35s ease;-o-transition:transform 0.35s ease;transition:transform 0.35s ease}@media (min-width: 760px){#bb-that .bb-that-header--sitemap-trigger:after{right:12px;top:2px;line-height:1}}@media (min-width: 1020px){#bb-that .bb-that--open{border-bottom:1px solid #474747}}#bb-that .bb-that--open .bb-that-header--sitemap-trigger:after{-webkit-transform:rotate(180deg);-ms-transform:rotate(180deg);-o-transform:rotate(180deg);transform:rotate(180deg)}
</style>
<div id="bb-that" data-alert-service="https://www.bloomberg.com/tophat/api/alerts?site=bcom">
	<nav class="bb-that">
		<header class="bb-that-header bb-that--container">
        <a class="bb-that-header__link bb-that-header--sitemap-trigger" href="http://www.bloomberg.com/company/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg the Company &amp; Its Products</a><a class="bb-that-header__link" href="https://bba.bloomberg.net/?utm_source=bloomberg-menu&amp;utm_medium=bcom"><span>Bloomberg Anywhere Remote Login</span><span>Bloomberg Anywhere Login</span></a><a class="bb-that-header__link" href="http://www.bloomberg.com/professional/request-demo/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-DEMO-bbgmenu">Bloomberg Terminal Demo Request</a>    </header>
		<div class="bb-that__sitemap bb-that--container">
    <div class="bb-that__close"></div>

        <ul class="bb-that__sitemap-sections bb-that--visible-md bb-that--visible-lg">
                    <li class="bb-that__col bb-that__col--md">
            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Bloomberg</h2>
    <div class="bb-that-category__content"><p class="bb-that-category__text">Connecting decision makers to a dynamic network of information, people and ideas, Bloomberg quickly and accurately delivers business and financial information, news and insight around the world.</p></div></section>            <section class="bb-that-category">
    <h2 class="bb-that-category__title">For Customers</h2>
    <div class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://bba.bloomberg.net/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Anywhere Remote Login</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/professional/downloads/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Software Updates</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://service.bloomberg.com/portal/sessions/new?utm_source=bloomberg-menu&amp;utm_medium=bcom">Manage Products and Account Information</a></li></div></section>            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Support</h2>
    <div class="bb-that-category__content"><p class="bb-that-category__text"><span>Americas</span>+1 212 318 2000</p><p class="bb-that-category__text"><span>EMEA</span>+44 20 7330 7500</p><p class="bb-that-category__text"><span>Asia Pacific</span>+65 6212 1000</p></div></section>    </li>
                    <li class="bb-that__col bb-that__col--md">
            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Company</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/company/london/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg London</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/company/?utm_source=bloomberg-menu&amp;utm_medium=bcom">About</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/careers/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Careers</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/diversity-inclusion/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Diversity and Inclusion</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/philanthropy/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Philanthropy and Engagement</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/impact/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Sustainability</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.techatbloomberg.com?utm_source=bloomberg-menu&amp;utm_medium=bcom">Tech</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/company/beta/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Beta</a></li></ul></section>            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Communications</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/company/announcements/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Press Announcements</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/company/press-contacts/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Press Contacts</a></li></ul></section>            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Follow</h2>
    <div class="bb-that-category__content"><li class="bb-that-category__item"><a href="http://www.facebook.com/Bloomberglp" class="bb-that-category__social-link bb-that--icon-facebook" target="_blank" rel="noopener">Facebook</a></li><li class="bb-that-category__item"><a href="https://twitter.com/bloomberg" class="bb-that-category__social-link bb-that--icon-twitter" target="_blank" rel="noopener">Twitter</a></li><li class="bb-that-category__item"><a href="https://www.linkedin.com/company/2494" class="bb-that-category__social-link bb-that--icon-linkedin" target="_blank" rel="noopener">LinkedIn</a></li><li class="bb-that-category__item"><a href="https://www.instagram.com/bloomberg/" class="bb-that-category__social-link bb-that--icon-instagram" target="_blank" rel="noopener">Instagram</a></li></div></section>    </li>
                    <li class="bb-that__col bb-that__col--md">
            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Products</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/professional/solution/bloomberg-terminal/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-SOLU-TERMINAL-bbgmenu">Bloomberg Terminal</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/professional/solution/execution-order-management/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-SOLU-EXORDMGMT-bbgmenu">Execution and Order Management</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/professional/solution/data-and-content/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-SOLU-DATACONT-bbgmenu">Data and Content</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/professional/solution/financial-data-management/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-SOLU-FINDATA-bbgmenu">Financial Data Management</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/professional/solution/integration-and-distribution/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-SOLU-INTEGDIST-bbgmenu">Integration and Distribution</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/professional/solution/tradebook/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-SOLU-TBOOK-bbgmenu">Bloomberg Tradebook</a></li></ul></section>            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Industry Products</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bna.com/bloomberglaw/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Law</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bna.com/tax?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Tax</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://about.bgov.com/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Government</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bna.com/ehs/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Environment</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://about.bnef.com/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg New Energy Finance</a></li></ul></section>    </li>
                    <li class="bb-that__col bb-that__col--md">
            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Media</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/markets/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Markets</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/technology/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Technology</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/pursuits/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Pursuits</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/politics/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Politics</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/view/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Opinion</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/businessweek/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Businessweek</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberglive.com/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Live Conferences</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloombergapps.com/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Apps</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloombergradio.com/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Radio</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/live?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Television</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/company/news-bureaus/?utm_source=bloomberg-menu&amp;utm_medium=bcom">News Bureaus</a></li></ul></section>            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Media Services</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/distribution?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Media Distribution</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloombergmedia.com/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Advertising</a></li></ul></section>    </li>
            </ul>

        <ul class="bb-that__sitemap-sections bb-that--visible-sm">
                    <li class="bb-that__col bb-that__col--sm">
            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Company</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/company/london/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg London</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/company/?utm_source=bloomberg-menu&amp;utm_medium=bcom">About</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/careers/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Careers</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/diversity-inclusion/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Diversity and Inclusion</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/philanthropy/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Philanthropy and Engagement</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/impact/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Sustainability</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.techatbloomberg.com?utm_source=bloomberg-menu&amp;utm_medium=bcom">Tech</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/company/beta/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Beta</a></li></ul></section>            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Communications</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/company/announcements/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Press Announcements</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/company/press-contacts/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Press Contacts</a></li></ul></section>            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Follow</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a href="http://www.facebook.com/Bloomberglp" class="bb-that-category__social-link bb-that--icon-facebook" target="_blank" rel="noopener">Facebook</a></li><li class="bb-that-category__item"><a href="https://twitter.com/bloomberg" class="bb-that-category__social-link bb-that--icon-twitter" target="_blank" rel="noopener">Twitter</a></li><li class="bb-that-category__item"><a href="https://www.linkedin.com/company/2494" class="bb-that-category__social-link bb-that--icon-linkedin" target="_blank" rel="noopener">LinkedIn</a></li><li class="bb-that-category__item"><a href="https://www.instagram.com/bloomberg/" class="bb-that-category__social-link bb-that--icon-instagram" target="_blank" rel="noopener">Instagram</a></li></ul></section>    </li>
                    <li class="bb-that__col bb-that__col--sm">
            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Products</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/professional/solution/bloomberg-terminal/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-SOLU-TERMINAL-bbgmenu">Bloomberg Terminal</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/professional/solution/execution-order-management/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-SOLU-EXORDMGMT-bbgmenu">Execution and<br /> Order Management</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/professional/solution/data-and-content/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-SOLU-DATACONT-bbgmenu">Data and Content</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/professional/solution/financial-data-management/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-SOLU-FINDATA-bbgmenu">Financial Data<br /> Management</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/professional/solution/integration-and-distribution/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-SOLU-INTEGDIST-bbgmenu">Integration and<br /> Distribution</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/professional/solution/tradebook/?utm_source=bloomberg-menu&amp;utm_medium=bcom&amp;bbgsum=DG-WS-PROF-SOLU-TBOOK-bbgmenu">Bloomberg<br /> Tradebook</a></li></ul></section>            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Industry Products</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bna.com/bloomberglaw/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Law</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bna.com/tax?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Tax</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://about.bgov.com/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Government</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bna.com/ehs/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Environment</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://about.bnef.com/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg New Energy Finance</a></li></ul></section>    </li>
                    <li class="bb-that__col bb-that__col--sm">
            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Media</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/markets/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Markets</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/technology/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg<br /> Technology</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/pursuits/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Pursuits</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/politics/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Politics</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/view/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Opinion</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloomberg.com/businessweek/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg<br /> Businessweek</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberglive.com/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Live Conferences</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloombergapps.com/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Apps</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://www.bloombergradio.com/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Radio</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/live?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Television</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/company/news-bureaus/?utm_source=bloomberg-menu&amp;utm_medium=bcom">News Bureaus</a></li></ul></section>            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Media Services</h2>
    <ul class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/distribution?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Media Distribution</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloombergmedia.com/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Advertising</a></li></ul></section>    </li>
                    <li class="bb-that__col bb-that__col--sm">
            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Bloomberg</h2>
    <div class="bb-that-category__content"><p class="bb-that-category__text">Connecting decision makers to a dynamic network of information, people and ideas, Bloomberg quickly and accurately delivers business and financial information, news and insight around the world.</p></div></section>            <section class="bb-that-category">
    <h2 class="bb-that-category__title">For Customers</h2>
    <div class="bb-that-category__content"><li class="bb-that-category__item"><a class="bb-that-category__link" href="https://bba.bloomberg.net/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Bloomberg Anywhere Remote Login</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://www.bloomberg.com/professional/downloads/?utm_source=bloomberg-menu&amp;utm_medium=bcom">Software Updates</a></li><li class="bb-that-category__item"><a class="bb-that-category__link" href="http://service.bloomberg.com/portal/sessions/new?utm_source=bloomberg-menu&amp;utm_medium=bcom">Manage Contracts and Orders</a></li></div></section>            <section class="bb-that-category">
    <h2 class="bb-that-category__title">Support</h2>
    <div class="bb-that-category__content"><p class="bb-that-category__text"><span>Americas</span>+1 212 318 2000</p><p class="bb-that-category__text"><span>EMEA</span>+44 20 7330 7500</p><p class="bb-that-category__text"><span>Asia Pacific</span>+65 6212 1000</p></div></section>    </li>
            </ul>
</div>	</nav>
</div>

                
            <div id="navi" class="navi navi-sub-menu-container" data-brand="technology" data-sticky="true" data-reg-env="production" style="z-index:2">
                <header class="navi-bar">
                    <div class="navi-bar__left"><!--
                    --><a href="/sitemap" class="navi-bar__button navi-bar__button--menu">Menu</a><!--
                    --><a href="/search" class="navi-bar__button navi-bar__button--search">Search</a><!--
                --></div>
                    <a href="/" class="navi-bar__logo">
                        <div class="navi-bar__logo--text"><span class="navi-bar__logo--title">Bloomberg</span></div>
                    </a>
                    <div class="navi-bar__right"><!--
                    --><a href="https://login.bloomberg.com/signup?in_source=login_direct" class="navi-bar__button navi-bar__button--sign-in navi-sign-in-link noscript-hide">Sign In</a><!--
                    --><a href="https://www.bloomberg.com/subscriptions?in_source=fs-nav" class="navi-bar__button navi-bar__button--subscribe navi-subscribe-link">Subscribe</a><!--
                --></div>
                </header>
            </div>
            <div class="navi-breaking-news" data-regions="global regional"></div>
        
                <main class="transporter-container">
                    <div class="transporter-item current">
                        
            <article class="" data-story-id="PCZCXF6S972801" data-theme="technology" data-type="article">
                <script class="blens-data" type="application/json">["2330:TT","AAPL:US","QCOM:US","005930:KS"]</script>
                <script id="piano-PCZCXF6S972801" type="application/json">{"excludeFromWall":false,"contentType":"article","publishedAt":"2018-08-05T10:57:08.085Z","theme":"technology-v2"}</script>
                <script id="article-info-PCZCXF6S972801" type="application/json">{"id":"PCZCXF6S972801","contentType":"article","contentTags":[{"id":"19362053","type":"Person","directScore":0.7118391660461653,"derivedScore":0.7118391660461653},{"id":"USD:CUR","type":"Currency","directScore":0.9089724497393895,"derivedScore":0.9089724497393895},{"id":"TXN:US","type":"Company","directScore":0.20848845867460908,"derivedScore":0.20848845867460908},{"id":"2454:TT","type":"Company","directScore":0.2146314221891288,"derivedScore":0.2146314221891288},{"id":"8316:JP","type":"Company","directScore":0.2656366344005957,"derivedScore":0.2656366344005957},{"id":"005930:KS","type":"Company","directScore":0.6431496649292628,"derivedScore":0.6431496649292628},{"id":"QCOM:US","type":"Company","directScore":1.0420699925539836,"derivedScore":1.0420699925539836},{"id":"AAPL:US","type":"Company","directScore":6.11187639612807,"derivedScore":6.11187639612807},{"id":"2330:TT","type":"Company","directScore":8.182692307692308,"derivedScore":8.182692307692308},{"id":"taipei","type":"City","directScore":0.885331347728965,"derivedScore":0.885331347728965},{"id":"android","type":"Topic","directScore":0.24646314221891288,"derivedScore":0.24646314221891288},{"id":"ipad","type":"Topic","directScore":0.3808637379002234,"derivedScore":0.3808637379002234},{"id":"banking","type":"Topic","directScore":0.39538346984363365,"derivedScore":0.39538346984363365},{"id":"smartphone","type":"Topic","directScore":0.6950856291883842,"derivedScore":0.6950856291883842},{"id":"software","type":"Topic","directScore":1.191734921816828,"derivedScore":1.191734921816828},{"id":"iphone","type":"Topic","directScore":9.21859193262639,"derivedScore":9.21859193262639},{"id":"TW","type":"Country","directScore":0.8840282948622487,"derivedScore":8.219570548022105},{"id":"currency","type":"Topic","directScore":0,"derivedScore":0.9089724497393895},{"id":"technology","type":"Classification","directScore":0,"derivedScore":8.992150847154727},{"id":"markets","type":"Classification","directScore":0,"derivedScore":6},{"id":"finance","type":"Classification","directScore":0,"derivedScore":0.2656366344005957},{"id":"Asia","type":"Region","directScore":0,"derivedScore":8.244252723218635},{"id":"JP","type":"Country","directScore":0,"derivedScore":0.2656366344005957},{"id":"KR","type":"Country","directScore":0,"derivedScore":0.6431496649292628},{"id":"US","type":"Country","directScore":0,"derivedScore":6.23904884448861},{"id":"US","type":"Region","directScore":0,"derivedScore":6.23904884448861},{"id":"mobile-phones","type":"Topic","directScore":0,"derivedScore":6.1481383405572885}]}</script>
                <script id="page-level-ad-config-PCZCXF6S972801" type="application/json">{"url":"2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus","adCode":"business/news/technology","targeting":{"suid":"PCZCXF6S972801","page":"articlejav","currentResource":"Story|PCZCXF6S972801","ni":["AGRKEY","ALLSTATES","ALLTOP","ALLWWCUR","AMFEAT","ASFEAT","ASIA","ASIAX","ATTACHMENT","BFWAS","BFWEQ","BFWEQEM","BFWFOCUS","BFWUS","BGOVBILLGO","BGOVCODES","BIZNEWS","BONDWIRES","BUSINESS","CA","CMDGLOMAC","CMDKEY","CNTOP","CNTOPZ2","CNTOPZ3","CONS","COS","CPR","DEVECO","ECO","ELE","EM","EQUITYKEY","ESGCONTROV","ESGRES","EUFEAT","FINNEWS","FINTECH","FIRSTWORD","FRXDIGITAL","G10MEMB","G7MEMB","GEN","GLOBFEAT","GOV","HANDHELD","HAR","INDUSTRIES","INTERNET","IPHONE","ITSECURE","ITSVC","LAW","LAWPRAC","MAJOR","MARKETS","METALKEY","MISC","MOBILE","MOV","MSCIEMAS","MSCINAMER","MSCIWORLD","NASIA","NASTOP","NASTOPZ2","NEGATIVE","NORTHAM","NRGKEY","OILKEY","ONWEB","PADD5","PADDIST","PHOTO","POLIRISK","PRIVACY","RET","SEM","SENTIMENT","SEQ","SOF","SPREGIONS","SRCRANK1","STK","SUPPLY","TEC","TECHTOP","TECHTOPZ1","TECHTOPZ2","TECSVC","TIMECO","TIMENI","TLS","TMT","TOP","TOPBIZMKT","TRD","TWN","UPDATE","US","USWE","WORLD","WRLS","WWTOP","WWTOPAM","WWTOPAS","WWTOPBIZ","WWTOPEU","WWTOPFEAT","WWTOPGLOB","WWTOPZ3"],"tagr":[],"kwl":["biz_xojet","biz_scandal","biz_testing123","biz_ishares","biz_pitney","biz_ubsbannedlist","biz_accentureindia1","biz_Samsung","biz_wellsfargosept","biz_bofasept","biz_samsungfito","biz_pnc","biz_googlelist","biz_googlelisttwo","biz_synchrony","biz_technologykeywords","biz_vices","biz_autocompetitors","biz_trowe","biz_zurichsmartmatch","biz_atrocity","biz_nomurakeywords","biz_etrade","biz_bp1","biz_bp2","biz_bp3","biz_bp4","biz_schwab","biz_fidelity","biz_tda","biz_ibm3","biz_dit_terrorism","biz_microsoft","biz_kornferry","biz_generic","biz_fti","biz_lexus1","biz_brandusa","biz_lexus2","biz_singlecountry2","biz_dun_bradstreet","biz_United","biz_BMW","biz_citi1","biz_apple","biz_att1","biz_mobkoimandslist","biz_tdameritrade","biz_boeing","biz_att2","biz_att4","biz_att5","biz_att6","biz_att7","biz_facebook1","biz_facebook2","biz_mulberry","biz_BMWRecall","biz_junctiondigital","biz_texas","biz_skymobkoi","biz_Fidelity_investopedia","biz_workdayusa","biz_masia1","biz_masia2","biz_mobkoibelvedere","biz_jpmorgan","biz_ishares2","biz_ishares3","biz_grapeshottest","biz_weaponsgrapeshot","biz_morg","biz_RBC","biz_spief","biz_CBA","biz_planes","biz_facebookmobkoi","biz_cmcmarketsuk","biz_amex1","biz_amex2","biz_amex3","biz_amex4","biz_amex5","biz_amex6"],"tickers":[{"id":"AAPL:US","score":6.11187639612807},{"id":"2330:TT","score":8.182692307692308}]},"disableAds":false}</script>
                
                
                
    <div class="lede-text-v2 lede">
        <div class="lede-text-v2__container">
            <div class="lede-text-v2__content">
                <div class="eyebrow-v2">technology</div>
                <h1 class="lede-text-v2__hed">iPhone Chipmaker Races to Recover After Crippling Computer Virus</h1>
                
                <address class="lede-text-v2__byline">By <div class="author-v2">
        <a class="author-v2__byline" href="https://www.bloomberg.com/authors/ATjxWD012Wk/debby-wu" rel="author">Debby Wu</a>
    </div> and <div class="author-v2">
        <a class="author-v2__byline" href="https://www.bloomberg.com/authors/AS7Hj1mBMGM/mark-gurman" rel="author">Mark Gurman</a>
    </div></address>
                <div class="lede-text-v2__times">
                    
        <time class="article-timestamp" itemprop="datePublished" datetime="2018-08-05T10:57:08.085Z" data-type="updated" data-status="">
            
        <script class="article-timestamp__format" type="application/json">
            {"year":"numeric","month":"long","day":"numeric","hour":"numeric","minute":"numeric","timeZoneName":"short"}
        </script>
        <noscript>August 5, 2018, 6:57 AM EDT</noscript>
    
        </time>
    
                    <span class="updated-wrap"><span class="updated-text">Updated on </span>
        <time class="article-timestamp" itemprop="dateModified" datetime="2018-08-06T02:28:27.638Z" data-type="updated" data-status="">
            
        <script class="article-timestamp__format" type="application/json">
            {"year":"numeric","month":"long","day":"numeric","hour":"numeric","minute":"numeric","timeZoneName":"short"}
        </script>
        <noscript>August 5, 2018, 10:28 PM EDT</noscript>
    
        </time>
    </span>
                </div>
            </div>
        </div>
    </div>
    
                <div class="content-well-v2">
                    <section class="main-column-v2">
                        
    <ul class="abstract-v2">
        
        <li class="abstract-v2__item">
            <div class="abstract-v2__item-text">
                TSMC expects full recovery Aug. 6 after suffering virus attack
            </div>
        </li>
        <li class="abstract-v2__item">
            <div class="abstract-v2__item-text">
                Incident to delay shipments and depress third-quarter revenue
            </div>
        </li>
    </ul>
                        
    <figure class="lede-small-image-v2 lede figure-expandable">
        <div class="image">
            
        <div id="lazy-img-329891249" class="lazy-img " >
            <style>#lazy-img-329891249:before{padding-top:66.68334167083543%;}</style>
            <img class="lazy-img__image"
                 src="https://assets.bwbx.io/images/users/iqjWHBFdfxIU/iSi6MA13on0A/v1/150x-1.jpg"
                 data-native-src="https://assets.bwbx.io/images/users/iqjWHBFdfxIU/iSi6MA13on0A/v1/-1x-1.jpg">
        </div>
        </div>
        
        <figcaption>
            
            <span class="lede-small-image-v2__caption caption"><p>The logic board of an Apple Inc. iPhone</p></span>
            
            <span class="lede-small-image-v2__credit credit">Photographer: Brent Lewin/Bloomberg</span>
        </figcaption>
    </figure>
                        <div class="body-columns">
                            <div class="middle-column">
                                
        <div class="body-copy-v2 fence-body">
            
        <aside class="left-column">
            
            
            
        <div class="text-to-speech">
            <div class="text-to-speech__label">LISTEN TO ARTICLE</div>
            <div class="text-to-speech__controls">
                <div class="text-to-speech__input-button"></div>
                <div class="text-to-speech__runtime" data-duration="307252">5:07</div>
            </div>
            <audio class="text-to-speech__audio-element">
                <source src="https://assets.bwbx.io/s3/readings/PD0PJF6S972A1533603186218.mp3" type="audio/mpeg">
            </audio>
        </div>
    
            
        <div class="share-article-button " data-variation="basic-article">
            <div class="share-article-button__label" onclick="">SHARE THIS ARTICLE</div>
            <div class="share-article-button__option"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.bloomberg.com%2Fnews%2Farticles%2F2018-08-05%2Fiphone-chipmaker-races-to-recover-after-crippling-computer-virus" class="share-article-button__link" rel="nofollow" data-new-window onclick="dataLayer.push({
        'event': 'article_social_share',
        'eventCategory': 'social',
        'eventAction': 'share',
        'eventLabel': 'facebook'
    })">
                <div class="share-article-button__icon share-article-button__icon-facebook"></div>
                Facebook
            </a></div>
            <div class="share-article-button__option"><a href="https://twitter.com/share?text=Taiwan%20Semiconductor%C2%A0races%20to%20recover%20from%20crippling%20computer%20virus&via=technology&url=https%3A%2F%2Fwww.bloomberg.com%2Fnews%2Farticles%2F2018-08-05%2Fiphone-chipmaker-races-to-recover-after-crippling-computer-virus" class="share-article-button__link" rel="nofollow" data-new-window onclick="dataLayer.push({
        'event': 'article_social_share',
        'eventCategory': 'social',
        'eventAction': 'share',
        'eventLabel': 'twitter'
    })">
                <div class="share-article-button__icon share-article-button__icon-twitter"></div>
                Twitter
            </a></div>
            <div class="share-article-button__option"><a href="https://www.linkedin.com/shareArticle?mini=true&title=iPhone%20Chipmaker%20Races%20to%20Recover%20After%20Crippling%20Computer%20Virus&summary=Taiwan%20Semiconductor%20Manufacturing%20Co.%2C%20which%20makes%20chips%20for%20the%20iPhone%20and%20other%20devices%2C%20is%20recovering%20from%20a%20debilitating%20computer%20virus%20but%20warned%20of%20delayed%20shipments%20and%20reduced%20revenue%20because%20of%20the%20impact%20on%20its%20factories.&url=https%3A%2F%2Fwww.bloomberg.com%2Fnews%2Farticles%2F2018-08-05%2Fiphone-chipmaker-races-to-recover-after-crippling-computer-virus" class="share-article-button__link" rel="nofollow" data-new-window onclick="dataLayer.push({
        'event': 'article_social_share',
        'eventCategory': 'social',
        'eventAction': 'share',
        'eventLabel': 'linkedin'
    })">
                <div class="share-article-button__icon share-article-button__icon-linkedin"></div>
                LinkedIn
            </a></div>
            <div class="share-article-button__option"><a href="mailto:?subject=iPhone%20Chipmaker%20Races%20to%20Recover%20After%20Crippling%20Computer%20Virus%20-%20Bloomberg&body=iPhone%20Chipmaker%20Races%20to%20Recover%20After%20Crippling%20Computer%20Virus%0D%0A%0D%0Aby%20Debby%20Wu%20and%20Mark%20Gurman%0D%0A%0D%0ATaiwan%20Semiconductor%20Manufacturing%20Co.%2C%20which%20makes%20chips%20for%20the%20iPhone%20and%20other%20devices%2C%20is%20recovering%20from%20a%20debilitating%20computer%20virus%20but%20warned%20of%20delayed%20shipments%20and%20reduced%20revenue%20because%20of%20the%20impact%20on%20its%20factories.%0D%0A%0D%0Ahttps%3A%2F%2Fwww.bloomberg.com%2Fnews%2Farticles%2F2018-08-05%2Fiphone-chipmaker-races-to-recover-after-crippling-computer-virus" class="share-article-button__link" rel="nofollow" onclick="dataLayer.push({
        'event': 'article_social_share',
        'eventCategory': 'social',
        'eventAction': 'share',
        'eventLabel': 'email'
    })">
                <div class="share-article-button__icon share-article-button__icon-email"></div>
                Email
            </a></div>
        </div>
    
        </aside>
    
            
            <p><a itemscope="itemscope" itemprop="StoryLink" href="/quote/2330:TT" title="Income statement" target="_blank"><meta itemprop="type" content="FunctionLink"><meta itemprop="security" content="2330 TT Equity"><meta itemprop="function" content="FA IS">Taiwan Semiconductor Manufacturing Co.</a>, which makes chips for the iPhone and other devices, is recovering from a debilitating computer virus but warned of delayed shipments and reduced revenue because of the impact on its factories.</p><div class="hardwall" data-position="1"></div><div class="softwall" data-position="1"></div><p>TSMC said that 80 percent of the fabrication tools affected by a virus outbreak Friday evening had been restored and that it expects full recovery on Monday. The Taiwanese company said the incident, which comes as it ramps up chipmaking for <a itemscope="itemscope" itemprop="StoryLink" href="/quote/AAPL:US" title="Company Overview"><meta itemprop="type" content="SecurityLink"><meta itemprop="url" content="bbg://securities/AAPL%20US%20Equity"><meta itemprop="security" content="AAPL US Equity">Apple Inc.</a>&#x2019;s next iPhones, would delay shipments, without specifying which customers would be affected. Its <a itemscope="itemscope" itemprop="StoryLink" href="/quote/2330:TT" title="Share Action" target="_blank"><meta itemprop="type" content="FunctionLink"><meta itemprop="security" content="2330 TT Equity"><meta itemprop="function" content="HCPI">shares</a> fell more than 1 percent in Taipei.</p><div class="hardwall" data-position="2"></div><div class="softwall" data-position="2"></div><p>Taiwan&#x2019;s largest company blamed the infection on a mistake made during software installation that then spread through its network. The chipmaker estimated that third-quarter revenue would be cut by about 3 percent from a previously <a itemscope="itemscope" itemprop="StoryLink" href="/quote/2330:TT" title="Guidance" target="_blank"><meta itemprop="type" content="FunctionLink"><meta itemprop="security" content="2330 TT Equity"><meta itemprop="function" content="GUID">forecast</a> $8.45 billion to $8.55 billion, while gross margin would slip by about 1 percentage point. It maintained its 2018 forecast of boosting revenue by high single digits in U.S. dollar terms.</p><div class="hardwall" data-position="3"></div><div class="softwall" data-position="3"></div>
        
        <div id="outstream-video-1-PCZCXF6S972801" class="outstream-ad" data-position="outstream-video">
            <script class="params" type="application/json">{"contentId":"PCZCXF6S972801","position":"outstream","dimensions":{"large_desktop":[[1,8]],"small_desktop":[[1,8]],"tablet":[[1,8]]},"strategy":"always","type":"Outstream Video Native Ad","targeting":{"position":"outstream","url":"/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus"},"containerId":"outstream-video-1-PCZCXF6S972801"}</script>
            <div class="outstream-video-ad-dummy"></div>
        </div>
        <div id="box-7yK1R52" class="page-ad" data-position="mobile-box">
            <script class="params" type="application/json">{"contentId":"PCZCXF6S972801","position":"box","dimensions":{"mobile":[[300,250],[1,1]]},"type":"Mobile Body Box Ad","positionIncrement":1,"targeting":{"position":"box1","positionIncrement":1,"url":"/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus"},"containerId":"box-7yK1R52"}</script>
            <div class="mobile-box-ad-dummy"></div>
        </div>
        <p>The incident underscores the global nature of the technology supply chain, in which companies like Apple and <a itemscope="itemscope" itemprop="StoryLink" href="/quote/QCOM:US" title="Company Overview"><meta itemprop="type" content="SecurityLink"><meta itemprop="url" content="bbg://securities/QCOM%20US%20Equity"><meta itemprop="security" content="QCOM US Equity">Qualcomm Inc.</a> depend on hundreds of suppliers around the world. This is the first time a virus had ever brought down a TSMC facility, recalling the <a itemscope="itemscope" itemprop="StoryLink" href="https://www.bloomberg.com/politics/articles/2017-12-19/u-s-blames-north-korea-for-cowardly-wannacry-cyberattack" title="U.S. Makes Case North Korea Was Behind WannaCry Cyber Attack (1)" target="_blank"><meta itemprop="type" content="StoryLink"><meta itemprop="suid" content="P17WEA6KLVR4">WannaCry</a> cyberattacks of 2017 that forced corporations around the world to suspend operations as they rooted out the ransomware. TSMC says no confidential information was compromised in the virus attack and most customers have been notified.</p><div class="hardwall" data-position="4"></div><div class="softwall" data-position="4"></div><p>Mark Li, an analyst at Sanford C. Bernstein, said he thinks all of TSMC&#x2019;s 12-inch wafer fabrication plants had been infected and that many customers had been affected, though the impact will be &#x201C;very limited&#x201D; because the company can make up for the losses during the busiest holiday quarter. TSMC makes Apple chips in its 12-inch fabrication plants.</p><p>&#x201C;Long-term, TSMC&#x2019;s trustworthy image is somewhat tainted but it is hard to quantify the effect now,&#x201D; Li wrote in a research note Monday.</p><figure data-type="image" data-id="329408000" data-image-type="photo" data-image-size="half" data-align="right" class="figure-expandable"><div class="image"><div id="lazy-img-329408000" class="lazy-img"><style>#lazy-img-329408000:before{padding-top:75.13333333333334%;}</style><img src="https://assets.bwbx.io/images/users/iqjWHBFdfxIU/iV9ttPqQgj60/v0/60x-1.jpg" data-native-src="https://assets.bwbx.io/images/users/iqjWHBFdfxIU/iV9ttPqQgj60/v0/-1x-1.jpg" class="lazy-img__image" data-img-type="image"></div></div><figcaption><div class="news-figure-caption-text caption"><p>Lora Ho</p></div><div class="news-figure-credit credit">Photographer: Maurice Tsai/Bloomberg</div></figcaption></figure><p>The firm is the latest to fall prey to a growing global scourge. Cyber crime could cost businesses as much as <a itemscope="itemscope" itemprop="StoryLink" href="https://www.bloomberg.com/politics/articles/2018-01-17/davos-elite-fear-cyberattacks-and-war-as-trump-stokes-tension" title="Davos Elite Fear Cyberattacks, War as Trump Stokes Tension (1)" target="_blank"><meta itemprop="type" content="StoryLink"><meta itemprop="suid" content="P2PE9G6JIJUP">$8 trillion</a> in damage over the next five years, according to the <a itemscope="itemscope" itemprop="StoryLink" href="/quote/48709Z:US" title="Company Overview"><meta itemprop="type" content="SecurityLink"><meta itemprop="url" content="bbg://securities/48709Z%20US%20Equity"><meta itemprop="security" content="48709Z US Equity">World Economic Forum</a>.</p><p data-tout-type="story"><a itemscope="itemscope" itemprop="StoryLink" href="https://www.bloomberg.com/politics/articles/2017-12-19/u-s-blames-north-korea-for-cowardly-wannacry-cyberattack" title="Click for full story" target="_blank"><meta itemprop="type" content="StoryLink"><meta itemprop="suid" content="P17WEA6KLVR4">Read more about the WannaCry attacks</a></p>
        <div id="in-article-Y1getNn" class="page-ad" data-position="in-article">
            <script class="params" type="application/json">{"contentId":"PCZCXF6S972801","position":"in-article","dimensions":{"mobile":[[5,19],[300,250],[1,1]],"tablet":[[5,19],[728,90],[1,1]]},"type":"In Article Flex Native Ad","positionIncrement":1,"targeting":{"position":"in-article","positionIncrement":1,"url":"/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus"},"containerId":"in-article-Y1getNn"}</script>
            <div class="in-article-ad-dummy"></div>
        </div>
        <p>&#x201C;TSMC has taken actions to close this security gap and further strengthen security measures,&#x201D; Chief Financial Officer Lora Ho said by phone Sunday.</p><p>The implications are unclear for Apple. The iPhone maker last week surpassed a market value of $1 trillion, largely on the strength of sales for its pioneering smartphone.</p><p data-tout-type="story"><a itemscope="itemscope" itemprop="StoryLink" href="https://www.bloomberg.com/news/articles/2018-08-02/apple-becomes-first-u-s-company-to-hit-1-trillion-market-value" title="Click for full story" target="_blank"><meta itemprop="type" content="StoryLink"><meta itemprop="suid" content="PCUOA3SYF01Y">Read more: Apple Becomes First U.S. Company to Hit $1 Trillion Value</a></p>
        <div id="outstream-video-2-PCZCXF6S972801" class="outstream-ad" data-position="outstream-video">
            <script class="params" type="application/json">{"contentId":"PCZCXF6S972801","position":"outstream","dimensions":{"mobile":[[1,8]]},"strategy":"always","type":"Outstream Video Native Ad","targeting":{"position":"outstream","url":"/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus"},"containerId":"outstream-video-2-PCZCXF6S972801"}</script>
            <div class="outstream-video-ad-dummy"></div>
        </div>
        <p>Still, TSMC&#x2019;s statement that the virus will affect shipments comes at a sensitive time for Apple, which is TSMC&#x2019;s largest customer and <a itemscope="itemscope" itemprop="StoryLink" href="/quote/2330:TT" title="Supply Chain Analysis" target="_blank"><meta itemprop="type" content="FunctionLink"><meta itemprop="security" content="2330 TT Equity"><meta itemprop="function" content="SPLC">accounts</a> for more than 21 percent of its revenue, according to data compiled by Bloomberg. Apple designs the processors that go into its devices, but it uses TSMC as its exclusive partner for producing the chips. In the past, the U.S. company has employed foundries owned by <a itemscope="itemscope" itemprop="StoryLink" href="/quote/005930:KS" title="Company Overview"><meta itemprop="type" content="SecurityLink"><meta itemprop="url" content="bbg://securities/005930%20KS%20Equity"><meta itemprop="security" content="005930 KS Equity">Samsung Electronics Co.</a>, its rival in global mobile devices.</p><p>Apple is <a itemscope="itemscope" itemprop="StoryLink" href="https://www.bloomberg.com/news/articles/2018-05-29/asia-display-makers-dip-on-report-apple-will-go-all-oled-in-2018" title="Apple Switch to All OLED IPhone Lineup Seen Unlikely by 2019 (1)" target="_blank"><meta itemprop="type" content="StoryLink"><meta itemprop="suid" content="P9IUTD6JIJUO">said</a> to be ramping up production of three new iPhone models for this fall, banking on them to continue its recent sales momentum. It&#x2019;s also planning new iPad and Apple Watch models, devices that have historically also used chips produced by TSMC. While TSMC has not indicated which customers could be affected, such a virus could potentially slow Apple&#x2019;s output of new devices, cutting into the number of units sold.</p><p>Apple does prepare for last minute supply-chain hiccups like the one facing TSMC and could work through any potential problems. An Apple spokesperson didn&#x2019;t immediately respond to a request for comment on Sunday.</p><p>&#x201C;If the most advanced 7nm process products suffer a major impact, then concern could arise over a potential launch delay for next-gen iPhones,&#x201D; SMBC Nikko analysts wrote on Monday.</p><p>While Qualcomm, which provides processors for many devices running Android software, gives TSMC about 6 percent of its revenues, it diversifies production so that some chips are built by competitors like Samsung. <a itemscope="itemscope" itemprop="StoryLink" href="/quote/40978Z:CH" title="Company Overview"><meta itemprop="type" content="SecurityLink"><meta itemprop="url" content="bbg://securities/40978Z%20CH%20Equity"><meta itemprop="security" content="40978Z CH Equity">Huawei Technologies Co.</a>, <a itemscope="itemscope" itemprop="StoryLink" href="/quote/2454:TT" title="Company Overview"><meta itemprop="type" content="SecurityLink"><meta itemprop="url" content="bbg://securities/2454%20TT%20Equity"><meta itemprop="security" content="2454 TT Equity">MediaTek Inc.</a>, Nvidia Corp., and <a itemscope="itemscope" itemprop="StoryLink" href="/quote/TXN:US" title="Company Overview"><meta itemprop="type" content="SecurityLink"><meta itemprop="url" content="bbg://securities/TXN%20US%20Equity"><meta itemprop="security" content="TXN US Equity">Texas Instruments Inc.</a> also rely on TSMC to produce chip designs.</p><aside class="inline-newsletter" data-state="ready"></aside><p>The incident comes weeks after TSMC cheered investors with a rosy <a itemscope="itemscope" itemprop="StoryLink" href="https://www.bloomberg.com/news/articles/2018-07-20/tsmc-jumps-as-investors-focus-on-glossier-smartphone-outlook" title="TSMC Jumps as Investors Focus on Glossier Smartphone Outlook (1)" target="_blank"><meta itemprop="type" content="StoryLink"><meta itemprop="suid" content="PC5QL86JTSF2">outlook</a> for smartphone demand in the latter half of the year. That helped the market look past a reduced revenue outlook. A bellwether for the chip industry as well as an early indicator of iPhone demand, it heads into its busiest quarters grappling with waning enthusiasm for the high-powered chips used to mine digital currencies. Chief Executive Officer C. C. Wei had said TSMC&#x2019;s sales will rise this year by a high single-digit percentage in U.S. dollar terms, down from an already reduced projection of about 10 percent.</p><p>The virus outbreak was due to &#x201C;misoperation&#x201D; during the software installation process for a new tool, the company said in the statement. The virus then spread once the tool was connected to TSMC&#x2019;s computer network.</p><p>&#x201C;TSMC has been attacked by viruses before, but this is the first time a virus attack has affected our production lines,&#x201D; Ho told Bloomberg News on Saturday.</p><p>(A previous version of this story was corrected to reflect the right type of margins affected)</p><div class="trashline">(<span itemprop="description">Updates with analyst&#x2019;s comment in the 13th paragraph.</span>)</div><ol class="noscript-footnotes"></ol>
        </div>
    
                                
                            </div>
                        </div>
                        
                        <div class="touts-v2">
                            
        <div class="secure-tip-tout-v2">
            <a class="secure-tip-tout-v2__link" href="https://www.bloomberg.com/tips/">Have a confidential news tip? Get in touch with our reporters.</a>
        </div>
                            
    <div class="terminal-tout-v2">
        <span class="terminal-tout-v2__text">Before it's here, it's on the Bloomberg Terminal.</span>
        <a href="https://bloom.bg/dg-ws-core-bcom-a1" class="terminal-tout-v2__link">LEARN MORE</a>
    </div>
    
                            
                        </div>
                        
                        
                        
                        
        <script id="page-level-taboola-config-PCZCXF6S972801" type="application/json">{"url":"https://www.bloomberg.com/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus"}</script>
        <div id="taboola-below-article-thumbnails-47bc8fd3cc5ca4f20abef80bfe617396" class="taboola"></div>
    
                    </section>
                    <aside class="right-rail right-rail-v2">
                        
                        
                        <div class="dry-container">
                        </div>
                        <div class="sticky-container">
                            
        <div class="mini-player">
            <div class="mini-player__details">
                <div class="mini-player__live-headline">LIVE ON BLOOMBERG</div>
                <a class="mini-player__link" href="https://www.bloomberg.com/live">Watch Live TV</a>
                <a class="mini-player__link" href="https://www.bloomberg.com/audio">Listen to Live Radio</a>
            </div>
            <a href="https://www.bloomberg.com/live" class="mini-player__video"></a>
        </div>
    
                            
                            
    <div id="box-YLpK7E9" class="box rotation-item page-ad" data-position="box">
        <script class="params" type="application/json">{"contentId":"PCZCXF6S972801","position":"box","dimensions":{"small_desktop":[[300,600],[300,250],[1,1]],"large_desktop":[[300,600],[300,250],[1,1]]},"positionIncrement":1,"targeting":{"position":"box1","positionIncrement":1,"url":"/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus"},"containerId":"box-YLpK7E9"}</script>
    </div>
    
                            
                            
        <div class="recirc-v2 rotation-item">
            <div class="recirc-v2__title">Most Read</div>
            <ol class="recirc-v2__list">
                
        <li class="recirc-v2__list-item recirc-v2__list-item-article">
            <div class="recirc-v2__eyebrow">markets</div>
            <a class="recirc-v2__list-item-article-link" href="https://www.bloomberg.com/news/articles/2018-08-05/saudi-arabia-suspends-diplomatic-trade-ties-with-canada">Saudi Slap at Canada Shows Crown Prince&apos;s Assertiveness</a>
            
        <time class="article-timestamp" itemprop="dateModified" datetime="2018-08-06T17:35:06.098Z" data-type="updated" data-status="do-not-localize">
            August 6, 2018, 1:35 PM EDT
        </time>
    
        </li>
        <li class="recirc-v2__list-item recirc-v2__list-item-article">
            <div class="recirc-v2__eyebrow">business</div>
            <a class="recirc-v2__list-item-article-link" href="https://www.bloomberg.com/news/articles/2018-08-06/china-prepared-for-long-trade-war-with-u-s-state-media-says">China Meets Trump&#x2019;s Tariff Hardball With Pledge to Endure</a>
            
        <time class="article-timestamp" itemprop="dateModified" datetime="2018-08-06T09:33:57.118Z" data-type="updated" data-status="do-not-localize">
            August 6, 2018, 5:33 AM EDT
        </time>
    
        </li>
        <li class="recirc-v2__list-item recirc-v2__list-item-article">
            <div class="recirc-v2__eyebrow">markets</div>
            <a class="recirc-v2__list-item-article-link" href="https://www.bloomberg.com/news/articles/2018-08-06/dimon-doubles-down-on-higher-u-s-yields-call-with-5-warning">Jamie Dimon Warns of 5% Treasury Yields</a>
            
        <time class="article-timestamp" itemprop="dateModified" datetime="2018-08-06T07:19:56.472Z" data-type="updated" data-status="do-not-localize">
            August 6, 2018, 3:19 AM EDT
        </time>
    
        </li>
        <li class="recirc-v2__list-item recirc-v2__list-item-article">
            <div class="recirc-v2__eyebrow">markets</div>
            <a class="recirc-v2__list-item-article-link" href="https://www.bloomberg.com/news/articles/2018-08-06/pepsi-s-first-female-ceo-to-end-12-year-run-replaced-by-insider">PepsiCo&apos;s Nooyi to Exit, Thinning the Ranks of U.S. Female CEOs</a>
            
        <time class="article-timestamp" itemprop="dateModified" datetime="2018-08-06T15:46:12.945Z" data-type="updated" data-status="do-not-localize">
            August 6, 2018, 11:46 AM EDT
        </time>
    
        </li>
        <li class="recirc-v2__list-item recirc-v2__list-item-article">
            <div class="recirc-v2__eyebrow">business</div>
            <a class="recirc-v2__list-item-article-link" href="https://www.bloomberg.com/news/articles/2018-08-06/negative-prices-in-power-market-as-wind-solar-cut-electricity">Power Worth Less Than Zero Spreads as Green Energy Floods the Grid</a>
            
        <time class="article-timestamp" itemprop="dateModified" datetime="2018-08-06T14:28:29.851Z" data-type="updated" data-status="do-not-localize">
            August 6, 2018, 10:28 AM EDT
        </time>
    
        </li>
            
    <li id="trendingnow-CLGCmh1" class="recirc-v2__list-item recirc-v2__list-item-ad" data-position="trendingnow">
        <script class="params" type="application/json">{"contentId":"PCZCXF6S972801","position":"trendingnow","dimensions":{"small_desktop":[[5,18],[1,1]],"large_desktop":[[5,18],[1,1]]},"positionIncrement":1,"targeting":{"position":"trendingnow1","positionIncrement":1,"url":"/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus"},"containerId":"trendingnow-CLGCmh1"}</script>
    </li></ol>
        </div>
                        </div>
                    </aside>
                </div>
            </article>
        
                        
                    </div>
                </main>
                <footer class="bb-global-footer"> <div class="bb-global-footer__content"> <div class="bb-global-footer__group"> <a class="bb-global-footer__link" href="http://www.bloomberg.com/tos">Terms of Service</a> <a class="bb-global-footer__link" href="http://www.bloomberg.com/trademarks">Trademarks</a> <a class="bb-global-footer__link" href="http://www.bloomberg.com/privacy">Privacy Policy</a> <small class="bb-global-footer__copyright">©2018 Bloomberg L.P. All Rights Reserved</small> </div> <div class="bb-global-footer__group"> <a class="bb-global-footer__link" href="http://www.bloomberg.com/careers/?utm_source=dotcom&utm_medium=footer">Careers</a> <a class="bb-global-footer__link" href="http://nytm.org/made-in-nyc">Made in NYC</a> <a class="bb-global-footer__link" href="http://bloombergmedia.com/">Advertise</a> <a class="bb-global-footer__link bb-global-footer__ad-choices" href="http://www.bloomberg.com/privacy#advertisements">Ad Choices</a> <a class="bb-global-footer__link" href="http://www.bloomberg.com/feedback">Contact Us</a> <a class="bb-global-footer__link" href="http://www.bloomberg.com/help">Help</a> </div> </div> </footer>
                
        <script>
            window["jvln-asset-prefix"] = "https://assets.bwbx.io/s3/javelin";
        </script>
        <script class="dependencies" type="application/json">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</script>
                <script class="content-data" type="application/json">{"adCode":"business/news/technology","attributor":"bn","brand":"technology","secondaryBrands":["business","technology"],"byline":"Debby Wu and Mark Gurman","franchise":null,"id":"PCZCXF6S972801","primaryCategory":"technology","categories":["technology"],"primarySite":"technology","publishedAt":"2018-08-05T10:57:08.085Z","seoHeadline":"iPhone Chipmaker Races to Recover After Crippling Computer Virus","slug":"2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus","textHeadline":"iPhone Chipmaker Races to Recover After Crippling Computer Virus","theme":"technology","topic":"iPhone","twitterHandle":"technology","twitterText":"Taiwan Semiconductor races to recover from crippling computer virus","type":"article","url":"/news/articles/2018-08-05/iphone-chipmaker-races-to-recover-after-crippling-computer-virus","webOriginal":false,"metadata":{"isMetered":true}}</script>
                
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/polyfills/polyfills-60a44ed0c6.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/ads/initialize/initialize_ads-c6a89c6bba.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/pianola/pianola-b42f956163.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("(min-width:761px)").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/ads/leaderboard/leaderboard-d5d33acd16.tablet-desktop.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/ads/outstream/outstream-38bbd9a23f.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/components/video_player/video_player-7a4ae6281d.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("(min-width:1021px)").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/layout/right_rail/right_rail-6f93c87d09.desktop.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("(min-width:761px)").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/components/text_to_speech/text_to_speech-87fc0a7a89.tablet-desktop.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/components/author_details/author_details-dc16c46e9f.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/components/blens/blens-9132b461ce.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
        <script type="text/javascript">
            if (window.matchMedia("(min-width:761px)").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/body/basic_redesign/transporter_teaser-ce41f489ae.tablet-desktop.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/components/charts/charts-dba3fc23e3.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/components/recirc_redesign/recirc_redesign-d0f776cd3a.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
        <script type="text/javascript">
            if (window.matchMedia("(min-width:1021px)").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/components/mini_player/mini_player-94dac8c6f1.desktop.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/ads/taboola/en/taboola-0d0ccf88fb.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
        <script type="text/javascript">
            if (window.matchMedia("(min-width:761px)").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/components/share_article_button/share_article_button-9b94960876.tablet-desktop.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/transporter/transporter-4b0593a7e4.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/analytics/geoip/geoip-eeb4578846.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                <script type="text/javascript">(function(d){var s=d.createElement("script");s.async=true;s.src="https://www.bloomberg.com/tophat/assets/v2.0.2/that.js";s.type="text/javascript";d.head.appendChild(s);})(document);</script>
                
            <script>window.Promise || document.write('<script src="https://assets.bwbx.io/s3/navi/vendor/js/promise-428cb78159.min.js"><\/script>')</script>
            <script src="https://assets.bwbx.io/s3/navi/js/header-03c1217684dc5619ba7b.js" async></script>
        
                
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/components/image_viewer/image_viewer-63b0a33e4a.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/dependencies/dependencies-8b55c67466.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/components/lazy_images/lazy_images-413510664c.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/components/third_party_embeds/third_party_embeds-e0ec0bac3a.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                
        <script type="text/javascript">
            if (window.matchMedia("all").matches) {
                var s = document.createElement("script");
                s.src = "https://assets.bwbx.io/s3/javelin/public/javelin/js/components/timestamp/timestamp-d8d2d2594a.js";
                s.type = "text/javascript";
                s.async = true;
                document.head.appendChild(s);
            }
        </script>
    
                <script src="https://assets.bwbx.io/s3/javelin/public/javelin/js/unsupportedBrowserMessage/unsupportedBrowserMessage-2cea176ceb.async.js" type="text/javascript" async></script>
                <!-- Google Tag Manager --><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.defer=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-MNTH5N');</script><!-- End Google Tag Manager -->
                <!-- Google Tag Manager (noscript) --><noscript><iframe src='https://www.googletagmanager.com/ns.html?id=GTM-MNTH5N' height='0' width='0' style='display:none;visibility:hidden'></iframe></noscript><!-- End Google Tag Manager (noscript) -->
            </body>
        </html>
    